Back to overview
Downtime
Internet Connectivity & External Phones
Dec 11, 2024 at 6:15pm UTC
Affected services
Woodridge - Network Connectivity
Woodridge - Wireless AP's
Woodridge - Phones
Resolved
Dec 11, 2024 at 7:34pm UTC
All issues resolved.
Affected services
Created
Dec 11, 2024 at 6:15pm UTC
NEOnet is aware of the issue.
Affected services